ecobee Shop Outage
Incident Report for ecobee
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 02, 2019 - 15:18 EDT
Investigating
We're currently experiencing an outage on shop.ecobee.com and shop-ca.ecobee.com through our third party store provider. We're aware of the issue, and have engaged our provider.
Posted 4 months ago. Jun 02, 2019 - 14:56 EDT
This incident affected: ecobee Shop.