ecobee Shop Outage
Incident Report for ecobee
Resolved
This incident has been resolved.
Posted 14 days ago. Jun 02, 2019 - 16:53 EDT
Investigating
We're currently experiencing an outage on shop.ecobee.com and shop-ca.ecobee.com through our third party store provider. We're aware of the issue, and have engaged our provider.
Posted 14 days ago. Jun 02, 2019 - 16:53 EDT
This incident affected: ecobee Shop.