Bug impacting Smart Thermostat Premium and SmartThermostat With voice control

Incident Report for ecobee

Monitoring

A fix for the bug impacting Smart Thermostat Premium and SmartThermostat with voice control devices that have been rebooted since Aug. 23 has begun rolling out.
Posted Sep 09, 2026 - 19:30 EDT

Identified

We’ve identified a bug impacting Smart Thermostat Premium and SmartThermostat with voice control, which is causing temperatures to read higher than they should. We’re actively working on a fix, and will provide updates as soon as possible on an estimated resolution.
Posted Sep 02, 2026 - 17:12 EDT