ecobee Shop Outage
Incident Report for ecobee
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 12:10 EST
Investigating
We're currently experiencing an outage on shop.ecobee.com and shop-ca.ecobee.com through our third party store provider. We're aware of the issue, and have engaged our provider.
Posted Feb 13, 2020 - 12:08 EST
This incident affected: ecobee Shop.