Investigating - We've received reports that ecobee Smart Doorbell Camera and SmartCamera devices are unable to be viewed in the Alexa app and on Echo Show devices. Our team is investigating. In the meantime, you can continue using the ecobee app to view the devices. Thank you for your patience as we work on resolving this issue. Stay tuned for updates.
Mar 14, 2024 - 12:10 EDT
Thermostat Online Services ? Operational
Switch+ Online Services ? Operational
SmartCamera Online Services Operational
Smart Security Online Services Operational
Alexa Voice Services ? Operational
ecobee Public API ? Operational
Mobile Services ? Operational
Subscriptions Operational
SmartBuildings ? Operational
Energy Services ? Operational
ecobee.com ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
ECP Planned Maintenance Apr 1, 2024 06:30-07:30 EDT
Update - We will be undergoing scheduled maintenance during this time.
Mar 27, 2024 - 10:37 EDT
Scheduled - ECP will be undergoing scheduled maintenance during this time. All ECP functionality will be unavailable to customers, including (but not limited to):
- Creating and cancelling demand response events
- Retrieving demand response utility and program information
- Creating, updating and deleting demand response programs and thermostat groups

Events that have previously scheduled to run during this time will still be run. However, event summary and runtime reports may not be accurate for events that overlap with the maintenance window.

We advise that any event creation or cancellation of events to occur during the maintenance window be made before 06:00EDT to ensure the changes are reflected on the thermostats before the maintenance window begins.

Mar 27, 2024 - 10:36 EDT
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024
Completed - The scheduled maintenance has been completed.
Mar 21, 08:04 EDT
Update - Scheduled maintenance is still in progress. We will provide updates as necessary.
Mar 21, 08:03 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 21, 07:00 EDT
Scheduled - On Thursday, March 21st between 7-9am ET, we’ll be performing scheduled improvements to ecobee SmartCamera and Smart Doorbell Camera. During the maintenance period, smart camera(s) will appear offline for approximately 20 minutes, but any camera that has detection enabled at the time of the maintenance should continue to record video and send push notifications. If a home is armed before this period, it remains protected with incident notifications and emergency escalation, if applicable. The siren (via devices and mobile app) and arming/disarming via the thermostat will be unavailable, but door/window sensors and thermostat comfort management will function as normal. Thanks for your patience and apologies for the inconvenience.
Mar 20, 17:19 EDT
Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024
Resolved - Case closed! The incident we were experiencing with the Google Home Third-Party Integration has been resolved. If you're still having some trouble, we suggest you try unlinking and then relinking your ecobee account from Google Home.
Mar 14, 15:50 EDT
Investigating - We've received reports that ecobee Smart Thermostats and Switch+ are appearing as "offline" in the Google Home app, making them unresponsive to control within the Google Home app. However, control of ecobee Smart Thermostats and Switch+ through Google Assistant voice commands should remain unaffected. Our team is investigating. In the meantime, you can continue using the ecobee app, Google Assistant, other third-party apps, or the devices themselves to control and adjust. Thank you for your patience as we work on resolving this issue. Stay tuned for updates.
Feb 23, 13:06 EST